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DIY Calculator Demo: Switches and LEDs 101 

Introduction 
This document features a suite of simple (but jolly interesting) demos that involve using a virtual 
computer-calculator to read data from some virtual switches, manipulate that data, and present 
the results on a variety of virtual display devices. 
 
This virtual computer-calculator, which is known as the DIY Calculator, accompanies the book 
How Computers Do Math (ISBN: 0471732788). If you don’t yet have version 4.0.7 or higher, you 
can download a free, fully-functional version of the software from www.DIYCalculator.com (you’ll 
find any necessary instructions on how to download and install the calculator on the website). 

A Quick Refresher: Computers and Calculators 
If you are already familiar with the concept of computers in general and the DIY Calculator in 
particular, then you can immediately jump to the section entitled Lab 1: Reading from the 8-Bit 
Switches, Writing to the 8-Bit LEDs. However, if you aren’t quite as confident as you’d like to 
be, it will be well worth your while to spend just a couple of minutes skimming through this 
brief introductory material. 
 
In its broadest sense, a computer is a device that can accept information from the outside world, 
process that information using logical and/or mathematical operations, make decisions based on 
the results of this processing, and – ultimately – return the processed information to the outside 
world in its new form (Figure 1). 
 

 

 
Figure 1. The main elements forming a computer  

 
 
The main elements forming a computer system are the central processing unit (CPU), the 
memory devices (ROM and RAM) that are used to store data and programs (sequences of 
instructions), and the input/output (I/O) ports that are used to communicate with the outside 
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world. (Figure 1 shows only a single input port and a single output port; in reality, the computer 
can have as many ports as its designers’ decide to implement.)  
 
The CPU is the "brain" of the computer, because this is where all of the number-crunching and 
decision-making is performed. Read-only memory (ROM) has its contents hard-coded as part of 
its construction and these values cannot be changed. By comparison, you can load new values 
into random access memory (RAM), read these values back out again later, and overwrite them 
with different values as required. One key point to remember about RAM is that it forgets its 
contents when power is removed from the system. 
 
The term “bus” is used to refer to a group of signals that carry similar information and perform a 
common function. A computer actually makes use of three buses called the control bus, address 
bus, and data bus. The CPU uses its address bus to “point” to other components in the system; it 
uses the control bus to indicate whether it wishes to “talk” (output/write/transmit data) or “listen” 
(input/read/receive data); and it uses the data bus to convey information (in the form of instructions 
and data) back and forth between itself and the other components. 
 
Our virtual computer is equipped with a data bus that is 8 bits wide and an address bus that is 16 
bits wide. This allows the address bus to point to 216 =  65,566 different memory locations, which 
are numbered from 0 to 65,535 in decimal; %0000000000000000 to %1111111111111111 in 
binary; or $0000 to $FFFF in hexadecimal (the concepts of binary and hexadecimal are briefly 
introduced below). 

Binary and Hexadecimal 
In a moment we’re going to create and run some simple programs, but before we start, we need 
to understand that computers store and manipulate data using the binary number system, which 
comprises just two digits: 0 and 1. One wire (or register bit or memory element) can be used to 
represent two distinct binary values: 0 or 1; two wires can represent four binary values: 00, 01, 
10, and 11; three wires can represent eight binary values: 000, 001, 010, 011, 100, 101, 110, 
and 111; and so on. As our virtual computer has an 8-bit data bus, this can be used to represent 
28 = 256 different binary values numbered from 0 
to 255 in decimal or %00000000 to %11111111 
in binary (where the “%” symbol is used to 
indicate a binary value). 
 
The problem is that humans tend to find it difficult 
to think in terms of long strings of 0s or 1s. Thus, 
when working with computers, we tend to prefer 
the hexadecimal number system, which 
comprises 16 digits: 0 through 9 and A through F 
as shown in Figure 2. 
 
In this case, we use “$” characters to indicate 
hexadecimal values. Each hexadecimal digit 
directly maps onto four binary digits (and vice 
versa of course). This explains why we noted 
earlier that our 16-bit address bus could be used 
to point to 216 =  65,566 different memory 
locations, which are numbered from $0000 to 
$FFFF in hexadecimal. 
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The Accumulator (ACC) and Status Register (SR) 
There are just a couple more things we need to know before we plunge headfirst into the fray. 
As illustrated in Figure 3, amongst other things, our CPU contains two 8-bit registers called the 
accumulator (ACC) and the status register (SR). (In this context, the term “register” refers to a 
special group of memory elements, each of which can store a single binary digit.)  
 

 
Figure 3. The accumulator (ACC) and status register (SR)  

 
As its name implies, the accumulator is where the CPU gathers, or “accumulates”, intermediate 
results. In the case of the status register, each of its bits is called a status bit, but they are also 
commonly referred to as status flags or condition codes, because they serve to signal (flag) that 
certain conditions have occurred. (All of these concepts are discussed in much greater detail in 
our book How Computers Do Math. For the purposes of these simple demos, we will introduce 
the various status bits on an as-needed basis.) 
  
Since we may sometimes wish to load the status register from (or store it to) the memory, it is 
usual to regard this register as being the same width as the data bus (8 bits in the case of our 
virtual system). However, our CPU employs only five status flags, which occupy the five least-
significant bits of the status register. This means that the three most-significant bits of the 
register exist only in our imaginations, so their non-existent contents are, by definition, 
undefined. 

Machine Code and Assembly Language 
If we wished, we could feed programs and data values into a computer as a series of numerical 
values; for example: 
 

$90 $10 $99 $F0 $31 $A0 $00 $00  
$92 $40 $15 $D1 $00 $00 $99 $F0 



Rev V1 Copyright © 2005 Clive “Max” Maxfield and Alvin Brown. All rights reserved. 4 

 
This style of representation is known as machine language or machine code, because this is the 
form that is directly understood and executed by the machine (computer). However, working at 
the machine code level is only slightly more fun than banging one’s head against a wall. 
 
Apart from anything else, working with machine code is time-consuming and prone to error. 
Humans tend to find it difficult to conceptualize things purely in terms of numbers; we much 
prefer to describe things using symbolic representations consisting of words and symbols. Thus, 
we would ideally prefer to describe our programs at a high level of abstraction (along the lines of 
“First do this; then do that; then do...”) and to then translate them into machine code for the 
computer to work with (Figure 4). 
 

 

Figure 4. It’s preferable to work at a higher level than machine code 
 
The Official DIY Calculator Data Book, which is to be found on the CD-ROM accompanying our 
book How Computers Do Math, introduces the concepts of first, second, third, fourth, and fifth 
generation programming languages (1GLs, 2GLs, 3GLs, 4GLs, and 5GLs, respectively).  For 
our purposes here, we need only note that each type of computer has its own machine code, 
and these languages are collectively referred to as first generation languages, or 1GLs for short. 
 
One step up the evolutionary ladder from machine code is assembly language. In this case, 
mnemonics are assigned to the various instructions and the programmer can also declare and 
use labels to make things easier to understand. For example, a typical assembly language 
statement might look like the following: 
 

STORE: STA [MAINDISP] 
 
A special program called an assembler is used to translate the assembly source code into its 
corresponding machine code. In some respects, assembly languages – which are referred to as 
second generation languages (2GLs) – may be considered only a small improvement over 
machine codes, but in other respects we may regard them as being a quantum leap. 
 
As we shall see in the following labs, we are going to create our programs in the DIY Calculator’s 
simple assembly language, assemble these programs into machine code, and run them on the 
virtual DIY Calculator.  
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Lab 1: Reading from the 8-Bit Switches, Writing to the 8-Bit LEDs 
If you don’t yet have the DIY Calculator on your computer, you can download a free copy and 
install it as described on our website. Now, use the Start > Programs > DIY Calculator > DIY 
Calculator command (or double-click the DIY Calculator icon on your desktop) to launch this 
little rapscallion, which should look something like the screenshot shown in Figure 5. 
 

 
 

Figure 5. Screenshot of the DIY Calculator’s primary interface  
 
Don’t Panic! This is the main calculator interface panel, which is the focus of the labs in our 
book How Computers Do Math. The only parts of this interface we’ll be using for the moment 
are the On/Off, Reset, Step, and Run buttons, which are used to control our virtual computer. 
 
Now use the Tools > Workbench #1 command to launch an interface that contains a number 
of switch input devices and light-emitting diode (LED) output devices as shown in Figure 6. 
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Figure 6. The workbench interface  

 
Drag this workbench away from the main calculator interface to an open area on your screen. 
Now try clicking some of the switches in one or both of the 8-bit switch banks: nothing happens 
(apart from the switches themselves flipping up and down), because (a) we haven’t powered our 
virtual computer up yet and (b) we don’t have a program to run even if the virtual computer was 
powered up. 
 
Speaking if which, it’s time to create our first program. Use the Tools > Assembler command 
(or click the appropriate icon in the main window’s tool bar) to launch the assembler, as shown 
in Figure 7. 
 

 
Figure 7. The DIY Calculator’s assembler 

 
OK, now we’re going to enter a really simple program into the assembler as shown in Figure 8. 
Enter this program, and then we’ll walk through it line-by-line explaining how it works. 
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Figure 8. The program for Lab 1 in its entirety 

 
The first line of the program begins by declaring a label called SW8BIT1 (which stands for “8-Bit 
Switch Bank 1”). Label names can contain up to eight letters, numbers, and underscore 
characters, but they must commence with a letter or underscore (the assembler treats 
uppercase and lowercase letters as being identical). Note that the label is terminated by a colon, 
but this doesn’t form part of the name. This label is associated with a hexadecimal value of 
$F000 using a .EQU (“equate”) command, where $F000 is the address of the virtual computer’s 
input port that is connected to the upper bank of switches in our workbench. The way this works 
is that, when we eventually come to run the assembler, every time it sees an instance of the 
label SW8BIT1 in our program, it will replace that instance with the numerical value $F000. One 
final point associated with this first line is that a “#” character (and any text following that 
character) are taken to be comments and are ignored by the assembler. 
 
Similarly, the second line of the program declares a label called LED8BIT (which stands for “8-
Bit LEDs”) and associates this label with a hexadecimal value of $F020, which is the address of 
the output port that is connected to the bank of 8-bit LEDs in our workbench. (This assembly 
language is, of course, presented in much greater detail in How Computers Do Math and also in 
The Official DIY Calculator Data Book, which was noted earlier in this paper.) 
 
Next, we use an .ORG (“origin”) command to instruct the assembler that the origin of our 
program is to be set to address $4000, which is the first location in the DIY Calculator’s RAM. 
(Addresses $0000 through $3FFF are occupied by the ROM. From our earlier discussions, you 
will recall that we use the RAM form of memory in which to store our programs.) 
 
Note that the .EQU, .ORG, and .END statements are known as pseudo-instructions or 
directives, because they serve only to “direct” the assembler and they don’t result in any actual 
machine code. Convention dictates that these directives are prefixed by period (full stop) 
characters, which provide a visual cue to the reader, thereby making the program slightly easier 
to understand.  
 
The main body of the program commences at the label LOOP. We start with a LDA (“load 
accumulator”) instruction, which we use to load the accumulator with whatever value is present 
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on the input port that is being driven by our upper bank of 8-bit switches. Next, we use a STA 
(“store accumulator”) instruction to copy the current contents of the accumulator to the output 
port that is driving the bank of 8-bit LEDs. Last but not least, we use a JMP (“unconditional 
jump”) to return us to the label LOOP, at which point we do the whole thing over again … and 
again … and again … and … 
 
And finally, the .END directive is, not surprisingly, used to inform the assembler that this is the 
end of our program. 
 
Use the assembler’s File > Save As command to save this file with the name wb101-lab1.asm. 
Next, use the assembler’s File > Assemble command to assemble this program into a 
corresponding machine code file, which will be automatically named wb101-lab1.ram. (If the 
assembler spots any finger-slip errors in your program, it will report these errors and you’ll have 
to cycle round correcting them and re-assembling the program until you are informed that 
everything is as it should be.) 
 
Now, click the On/Off button on the calculator’s front panel to power-up the virtual computer; 
use the Memory > Load RAM command in the main window to locate the wb101-lab1.ram 
machine code file you just created and load it into the virtual computer’s memory; and click the 
Run button on the calculator’s front panel to set your program running. 
 
Initially, nothing appears to be happening, but this is because all of the switches on the 
Workbench are in their down positions, which equates to “Off” in our virtual world. Thus, when 
the program reads a value from the switches and writes this value to the LEDs, they remain in 
their “Off” states. Now try clicking one or more of the switches forming our 8-Bit Switch Bank 1 
and observe what happens to the 8-bit LEDs (an example configuration with the switches set to 
a binary pattern of 01000111 [hexadecimal $47] is shown in Figure 9). 
 

 
Figure 9. Reading from the 8-bit switches, writing to the 8-bit LEDs 

 
We’ll explain the workings of the switches in a little more detail below. For the moment, once 
you’ve finished playing, click the Reset button on the calculator’s front panel to halt this 
program, and then click the On/Off button to power-down the virtual computer. 
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An Aside – How This All Works In the Real World 
Actually, you don’t really need to know this bit, so you can jump straight into the next lab if you 
so desire. However, generally speaking, the more we know about something, the more other 
things start to make sense, and the more fun we have. 
 
In the previous lab, we created a program that looped around reading a value from the input 
port at address $F000 that is connected to the upper bank of 8-bit switches, and then copying 
this value to the output port at address $F020 that drives the lower bank of 8-bit LEDs. Before 
we go any further, let’s take a moment to consider how this works in a little more detail. 
 
First, let’s remind ourselves that the central processing unit (CPU) in our virtual computer 
contains an 8-bit register called the accumulator (ACC), which is used to gather, or accumulate, 
intermediate results. For reasons that are more fully explained in our book How Computers Do 
Math, these bits are numbered right-to-left from 0 to 7 (Figure 10.) 
 

 
Figure 10. The CPU contains an 8-bit register called the accumulator 

 
Now, consider the upper bank of 8-bit switches on the workbench. As we noted, these are 
connected to the input port at address $F000. These switches are arranged such that the right-
hand switch is connected to bit 0 of the port, while the left-hand switch is connected to bit 7 of 
the port (Figure 11). 
 

 

Figure 11. The upper 8-bit bank of switches (logical view) 
 
And of course, not surprisingly, when we use a LDA (“load accumulator”) instruction to copy the 
value from the input port into the accumulator, bit 0 from the input port gets loaded into bit 0 of 
the accumulator, bit 1 from the input port gets loaded into bit 1 of the accumulator, bit 2 from the 
input port gets loaded into bit 2 of the accumulator, and so forth. 
 
But what’s “behind” these switches? Well, consider the circuit diagram shown in Figure 12. 
Don’t Panic! This is not as complicated as it seems. First of all we have eight wires that we have 
decided to call in_data[0] through in_data[7]. Each of these wires has a simple electronic 
component called a resistor attached to it; the other sides of the resistors are all connected to 0 
volts or ground, which we will take to represent both logical and binary 0. This means that if all 
of the switches are in their “Open” or “Off” positions as shown in Figure 12, then all of the 
in_data[7:0] wires will be connected to logic 0 values via their respective resistors. Thus, 
when the switches are in these positions, a binary value of %00000000 will be conveyed to the 
accumulator via the CPU’s data bus when we read a value from the input port that’s being “fed” 
by the switches in this circuit. 
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Figure 12. Circuit diagram of upper bank of switches (physical view), all switches open  
 
Note that the two supply values of 0 volts and +5 volts shown in this circuit diagram are used 
here only for example. In the real world, different computer systems and input/output devices 
may use different supply voltages. For the purposes of these discussions, we need only be 
aware that we’re considering 0 volts to correspond to a logical 0 or a binary 0 value, while +5 
volts corresponds to a logical 1 or binary 1 value. 
 
In the case of our workbench, the “Open” or “Off” switch state corresponds to the switch being in 
its “Down” Position. Now, let’s suppose that we are running the program from the previous lab 
and we transition the switches 6, 2, 1, and 0 on the workbench into their “Up” / “On / “Closed” 
positions as shown in Figure 13. 
 

 

Figure 13. Switches 6, 2, 1, and 0 on the upper panel are Up / On / Closed 
 
This corresponds to the circuit diagram being in the state shown in Figure 14. It’s important to 
note that the resistors in these circuit diagrams (which would be referred to as “pull-down” 
resistors because they are trying to pull their respective signals “down” to logic 0) would have a 
high value. For reasons we don’t need to go into here,1 this means that the logic 0 values they 
                                                 
1 If you want to know more about how resistors and related components work, may we refer you to our 
book Bebop to the Boolean Boogie (An Unconventional Guide to Electronics), ISBN: 0750675438. 
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are applying to their respective signals are relatively weak. In turn, this means that when a 
switch is closed, it will overwrite the value on its corresponding in_data signal with a logic 1. 
Thus, when the switches are in the positions shown in Figures 13 and 14, a binary value of 
%01000111 will be conveyed to the accumulator via the CPU’s data bus when we read a value 
from this input port. 
 

 

Figure 14. Circuit diagram of upper bank of switches, switches 6, 2, 1, 0 closed  
 
Now let’s turn our attention to the 8-bit bank of LEDs on the workbench. As we previously 
discussed, these are connected to the output port at address $F020. Not surprisingly, we’ve 
arranged these little scamps such that the right-hand LED is connected to bit 0 of the port, while 
the left-hand LED is connected to bit 7 of the port (Figure 15). 
 

 

Figure 15. The 8-bit bank of LEDs (logical view) 
 
And we can only imagine your surprise to learn that, when we use a STA (“store accumulator”) 
instruction to copy the value in the accumulator to the output port driving these LEDs, bit 0 from 
the accumulator is copied to bit 0 of the output port, bit 1 from the accumulator is copied to bit 1 
of the output port, bit 2 from the accumulator is copied to bit 2 of the output port, and so forth. 
 
Last but not least, before we leap into the next lab with gusto and abandon, let’s take a moment 
to consider what’s “behind” these LEDs? Well, a semiconductor diode is a component that 
conducts electricity in only one direction (Figure 16a). By introducing extremely thin layers of 
esoteric materials into semiconductor diodes during their construction, they can be made to emit 
light when they are conducting (Figure 16b), and these components are therefore known as 
light-emitting diodes (LEDs). 
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Figure 16. Standard diodes versus light-emitting diodes 
 

Depending on the materials used, it is possible to create LEDs that emit red, green, yellow, 
orange, and – most recently – blue light. The red ones are the easiest and cheapest to make, 
which is why all of the original electronic calculators and digital watches used them (the first red 
LEDs started to appear on the market in the late 1960s). By comparison, the blue ones are 
harder to make and are comparatively expensive (in fact, it wasn’t until 1996 that the Japanese 
electrical engineer Shuji Nakamura demonstrated the first blue LED). In the case of the DIY 
Calculator’s workbench, we have equipped it with the finest virtual green LEDs money can buy! 
 
Finally, consider the circuit diagram illustrated in Figure 17. This represents the output port at 
address $F020 that is driving the bank of 8-bit LEDs on the workbench. The way this works is 
that the output port is actually an 8-bit register, or memory element. When the CPU writes a 
value to this port, the register will remember that value – and will continue to drive it to the 
outside world – until the CPU writes a new value to the port. 
 

 

Figure 17. Circuit diagram for the bank of 8-bit LEDs  
 
In the case of an output port bit that is driving a logic 0, the LED connected to this bit will have a 
logic 0 value on both of its terminals, which means that no current will flow and the LED will not 
glow. By comparison, in the case of an output port bit that is driving a logic 1, the LED 
connected to this bit has a logic 1 on its “input” and a logic 0 on its “output,” so this LED will be 
turned on and will therefore glow (bright green in the case of the LEDs on our workbench). 
 
So, let’s suppose that the CPU writes a binary value of %01000111 to this output port. This will 
cause the LEDs connected to bits 7, 5, 4, and 3 to be turned off, while the LEDs connected to 
bits  6, 2, 1, and 0 will be turned on; and the result will be as illustrated in Figure 15. 
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Lab 2: Reading from the 8-Bit Switches, Writing to the Single  
Un-decoded 7-Segment Display  

If you haven’t already done so, launch the DIY Calculator and use the Tools > Workbench #1 
command to access the interface that contains the switch input devices and light-emitting diode 
(LED) output devices as shown in Figure 18. 
 

 
Figure 18. The workbench interface  

 

Although the 8-bit LED display we used in the previous lab can be very useful, we sometimes 
prefer to see information being presented in a more human-readable form. Observe the 
numerical-looking displays toward the right-hand side of the workbench. From left-to-right these 
are a single un-decoded 7-segment display, a single decoded 7-segment display, and a dual 
decoded 7-segment display.  
 

These are known as 7-segment displays because, not surprisingly, they are each formed from 
seven segments; in turn, each segment is formed from a LED. For the purposes of this lab, we 
will be working with the single un-decoded 7-segment display (the one annotated with the text 
“7-Seg Un-Dec”). So what do we mean by un-decoded? Well, the easiest way to explain this is 
by means of a picture (Figure 19). 
   

 

Figure 19. Single un-decoded 7-segment display  
 

The seven LEDs forming this device will be encapsulated in a common package (similar to an 
integrated circuit package) that can be attached to a display panel or a circuit board. In the case 
of our virtual device, only seven segments are required, so bit 7 from the output port remains 
unused and our hypothetical package would require only eight pins, one for each of the LEDs 
and a common pin connected to 0 volts (logic 0). The package’s actual pin assignments are 
irrelevant to us, so long as we connect the pin associated with LED ‘A’ to bit 0 from the output 
port, the pin associated with LED ‘B’ to pin 1 from the port, and so forth. 
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Just for giggles and grins, Figure 20 shows a picture of a circuit board we designed a few years 
ago as part of another project. You can see twelve 7-segment displays toward the lower left-
hand side of the board (in this particular case, these were dual decoded 7-segment displays as 
discussed in lab 4 later in this paper). 
 

 
Figure 20. A real-world circuit board featuring a number of 7-segment displays 

Photo by Alan Winstanley (http://homepages.tcp.co.uk/~alanwin)  
 
So what can we do with our un-decoded 7-segment display? Well, for one thing, by activating 
the appropriate segments, we can represent the hexadecimal characters ‘0’ through ‘9’ and ‘A’ 
through ‘F’ as illustrated in Figure 21 (note that we are limited to lowercase representations of 
the letters ‘b’ and ‘d’).  
 

 

Figure 21. Representing the hexadecimal characters ‘0’ – ‘9’ and ‘A’ – ‘F’ 
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And thus we arrive at our second program. Use the Tools > Assembler command (or click the 
appropriate icon in the main window’s tool bar) to launch the assembler. Use the assembler’s 
File > Open command to locate and open the wb101-lab1.asm that we created in the first lab, 
and then use the assembler’s File > Save As command save this out as wb101-lab2.asm. Now 
modify the program by adding two lines (these modifications are in bold and highlighted in gray 
as shown below): 
 

SW8BIT1:  .EQU   $F000     # Input port from upper 8-bit switches 
LED8BIT:  .EQU   $F020     # Output port to 8-bit LEDs 
SUD7SEG:  .EQU   $F021     # Output port to single un-decoded 7-segment 
 

          .ORG   $4000     # Set program origin 
LOOP:      LDA   [SW8BIT1] # Read from upper 8-bit switches 
           STA   [LED8BIT] # Write to 8-bit LED Display 
           STA   [SUD7SEG] # Write to single un-decoded 7-segment display 
           JMP   [LOOP]    # Do it all again 
          .END 

 
As you will recall, our original program used to loop around reading from the upper bank of 8-bit 
switches (connected to the input port at address $F000) and writing to the bank of 8-bit LEDs 
(driven by the output port at address $F020). 
 
All we’ve done is to add a new label called SUD7SEG (which stands for “single un-decoded 
7-segment display”) and to associate this label with a hexadecimal value of $F021, which is 
the address of the output port driving the single un-decoded 7-segment display.  
 
Also, in the main loop, once we’ve read a value from the 8-bit switches and saved it out to the  
8-bit LEDs, we also copy this value to the output port driving the single un-decoded 7-segment 
display. 
 
Once you’ve made these modifications, use the assembler’s File > Save command to save your 
work, and then use the assembler’s File > Assemble command to assemble this program into a 
corresponding machine code file, which will be automatically named wb101-lab2.ram. 
 
Click the On/Off button on the calculator’s front panel to power-up the virtual computer; use the 
Memory > Load RAM command in the main window to locate the wb101-lab2.ram machine 
code file you just created and load it into the virtual computer’s memory; and click the Run 
button on the calculator’s front panel to set your program running. 
 
Once again, nothing appears to be happening at first, but this is because all of the switches on 
the Workbench are in their down positions, which equates to “Off” in our virtual world. Now try 
clicking one or more of the switches forming our 8-Bit Switch Bank 1 and observe what happens 
to the 8-bit LEDs and the single un-decoded 7-segment display (Figure 22). 
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Figure 22. Writing to the 8-bit LED and single un-decoded 7-segment display 
 
Experiment by constructing the LED combinations shown in Figure 21 (you may find Figure 19 
useful for determining which bit drives which segment on the display). Don’t shirk! Replicate all 
of the patterns because you need to get a feel for how awkward this is before moving on to the 
next lab. Once you’ve finished playing, click the Reset button on the calculator’s front panel to 
halt this program, and then click the On/Off button to power-down the virtual computer. 
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Lab 3: Reading from the 8-Bit Switches, Writing to the Single  
Decoded 7-Segment Display  

If you haven’t already done so, launch the DIY Calculator and use the Tools > Workbench #1 
command to access the interface that contains the switch input devices and light-emitting diode 
(LED) output devices as shown in Figure 23. 
 

 
Figure 23. The workbench interface  

 

In the previous lab, we used the upper bank of 8-bit switches in conjunction with the un-decoded 
7-segment display to construct patterns representing the hexadecimal characters ‘0’ through ‘9’ 
and ‘A’ through ‘F’. It won’t have taken long for you to realize that this is a somewhat painful 
method of doing things.  
 

There are ways we could make this easier by playing cunning tricks in our programs. Take a 
few moments to see if you can think of a technique we could use (an example is given at the 
end of this lab, but don’t cheat – mull this problem over while you are performing this lab, and 
we’ll see how well you did later). 
 

As opposed to addressing this problem in software (by modifying our programs), we could 
address it in hardware. For example, we could create a special block of decoder logic as shown 
in Figure 24. 
 

 

Figure 24. Single decoded 7-segment display  
 

Remember that four bits can represent 24 = 16 different patterns of 0s and 1s from 0000 to 
1111. As was illustrated in Figure 2, these patterns can be used to represent the hexadecimal 
digits ‘0’ to ‘9’ and ‘A’ to ‘F’. Thus, our special block of decoder logic could take the four least-
significant bits from the output port and – depending on the binary value on these bits – 
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generate the appropriate signals required to drive the 7-segment display. (Note that the decoder 
logic could theoretically be constructed out of discrete logic gates or provided as a special 
device, but it would most often be incorporated as part of the 7-segment display itself.) 
 
OK, it’s time to create our third program. Use the Tools > Assembler command (or click the 
appropriate icon in the main window’s tool bar) to launch the assembler. Use the assembler’s 
File > Open command to locate and open the wb101-lab2.asm that we created in the second 
lab, and then use the assembler’s File > Save As command save this out as wb101-lab3a.asm. 
Now modify the program by adding two lines (these modifications are in bold and highlighted in 
gray as shown below): 
 

SW8BIT1:  .EQU   $F000     # Input port from upper 8-bit switches 
LED8BIT:  .EQU   $F020     # Output port to 8-bit LEDs 
SUD7SEG:  .EQU   $F021     # Output port to single un-decoded 7-segment 
SD7SEG:   .EQU   $F022     # Output port to single decoded 7-segment 
 

          .ORG   $4000     # Set program origin 
LOOP:      LDA   [SW8BIT1] # Read from upper 8-bit switches 
           STA   [LED8BIT] # Write to 8-bit LED Display 
           STA   [SD7SEG]  # Write to single decoded 7-segment display 
           STA   [SUD7SEG] # Write to single un-decoded 7-segment display 
           JMP   [LOOP]    # Do it all again 
          .END 

 
As before, this program loops around reading from the upper bank of 8-bit switches (connected 
to the input port at address $F000) and writing to the various displays. All we’ve done is to add a 
new label called SD7SEG (which stands for “single decoded 7-segment display”) and to 
associate this label with a hexadecimal value of $F022, which is the address of the output port 
driving the single decoded 7-segment display.  
 
Also, in the main loop, once we’ve read a value from the 8-bit switches and saved it out to the  
8-bit LEDs, we copy this value to the output ports driving both the single decoded and un-
decoded 7-segment displays. (Observe that, in the case of this program, we’ve decided to write 
to the decoded 7-segment display before we write to the un-decoded version. In reality, the 
order in which we write to these two 7-segment displays make no difference whatsoever in the 
case of this particular program. The only reason we used this specific order is to make things 
easier when we come to modify the program later in this lab.)  
 
Once you’ve made the above modifications, use the assembler’s File > Save command to save 
your work, and then use the assembler’s File > Assemble command to assemble this program 
into a corresponding machine code file, which will be automatically named wb101-lab3a.ram. 
 
Click the On/Off button on the calculator’s front panel to power-up the virtual computer; use the 
Memory > Load RAM command in the main window to locate the wb101-lab3a.ram machine 
code file you just created and load it into the virtual computer’s memory; and click the Run 
button on the calculator’s front panel to set your program running. 
 
Observe that the 8-bit LEDs and the segments forming the un-decoded 7-segment display are 
initially off. This is because all of the switches are in their Down/Off/Logic 0 positions. By 
comparison, the single decoded 7-segment display is showing the number ‘0’, which 
corresponds to the four least-significant (right-hand) switches representing binary 0000.  
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Now try clicking the various switches forming 8-Bit Switch Bank 1. Observe that, while bits 0 
through 7 affect the un-decoded 7-segment display, only bits 0 through 3 affect the single 
decoded 7-segment display (Figure  25). 
 

 

Figure 25. Writing to the single un-decoded and single decoded 7-segment displays 
 
Once you’ve finished playing, click the Reset button on the calculator’s front panel to halt this 
program, and then click the On/Off button to power-down the virtual computer. 
 
And finally, do you recall our question earlier in this lab as to how we could modify our programs 
so as to make it easier to construct patterns on the un-decoded 7-segment display? One way in 
which we could do this is as follows. Use the assembler to open wb101-lab3a.asm and save it 
out as wb101-lab3b.asm, then make the following modifications shown in bold and highlighted 
in gray: 
 

SW8BIT1:  .EQU   $F000       # Input port from upper 8-bit switches 
LED8BIT:  .EQU   $F020       # Output port to 8-bit LEDs 
SUD7SEG:  .EQU   $F021       # Output port to single un-decoded 7-segment 
SD7SEG:   .EQU   $F022       # Output port to single decoded 7-segment 
 

          .ORG   $4000       # Set program origin 
LOOP:      LDA   [SW8BIT1]   # Read from upper 8-bit switches 
           STA   [LED8BIT]   # Write to 8-bit LED Display 
           STA   [SD7SEG]    # Write to single decoded 7-seg display 
GETPAT:    AND   %00001111   # Mask out the MS four bits 
           STA   [TEMPX+1]   # Store ACC to LS of temp X 
           BLDX  [TEMPX]     # Load the index register 
           LDA   [NUM_0_3,X] # Load ACC with correct pattern 
           STA   [SUD7SEG]   # Write to single un-decoded 7-seg display 
           JMP   [LOOP]      # Do it all again 
 

TEMPX:    .2BYTE $0000 
NUM_0_3:  .BYTE  %00111111, %00110000, %01011011, %01001111 
NUM_4_7:  .BYTE  %01100110, %01101101, %01111101, %00000111 
NUM_8_B:  .BYTE  %01111111, %01100111, %01110111, %01111100 
NUM_C_F:  .BYTE  %00111001, %01011110, %01111001, %01110001 
 

          .END 
 
First of all, let’s look at the modifications at the end of the program. At label TEMPX (“temporary 
index register”) we reserve a 2-byte field and load it with all zeros. Next, starting at label 
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NUM_0_3, we reserve sixteen 1-byte fields and load them with binary patterns. If presented to 
the un-decoded 7-segment display, the first pattern (%00111111) will light the segments 
corresponding to the hexadecimal digit ‘0’; the second pattern (%00110000) will light the 
segments corresponding to the hexadecimal digit ‘1’; and so forth to the last pattern 
(%01110001),  which will light the segments corresponding to the hexadecimal digit ‘F’. 
 
Now, let’s consider the modifications to the body of the program starting at label GETPAT (“get 
pattern”). First, we use a logical AND instruction to clear the most-significant four bits in the 
accumulator to zero. Next, we store the value in the accumulator into the least-significant byte of 
our 2-byte TEMPX field, and then we use a BLDX (“big load index register”) instruction to load our 
16-bit index (X) register with the two bytes from the TEMPX field. (The index register and its 
associated instructions are introduced in more detail in How Computers Do Math.) 
 
The point here is that if the accumulator initially contained $00, the index register now contains 
$0000; if the accumulator initially contained $01, the index register now contains $0001, and so 
forth. Now, we use the LDA [NUM_0_3,X] to load the accumulator using the indexed 
addressing mode; in this case, the accumulator will be loaded with the contents of the memory 
location whose address is calculated by adding the contents of the index (X) register to the 
address associated with label NUM_0_3. Thus, if the index register contains $0000, the 
accumulator will be loaded with the binary pattern from the address associated with label 
NUM_0_3; if the index register contains $0001, the accumulator will be loaded with the binary 
pattern from the address associated with label NUM_0_3 + $0001; and so forth.  
 
Once you’ve made the above modifications, use the assembler’s File > Save command to save 
your work, and then use the assembler’s File > Assemble command to assemble this program 
into a corresponding machine code file, which will be automatically named wb101-lab3b.ram. 
 
Click the On/Off button on the calculator’s front panel to power-up the virtual computer; use the 
Memory > Load RAM command in the main window to locate the wb101-lab3b.ram machine 
code file you just created and load it into the virtual computer’s memory; and click the Run 
button on the calculator’s front panel to set your program running. 
 
Observe that both the un-decoded and decoded versions of the 7-segment displays now reflect 
exactly the same patterns (Figure 26). 
 

 

Figure 26. Performing decoding for the un-decoded display in software 
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Lab 4: Reading from the 8-Bit Switches, Writing to the Dual Decoded  
7-Segment Display  

If you haven’t already done so, launch the DIY Calculator and use the Tools > Workbench #1 
command to access the interface that contains the switch input devices and light-emitting diode 
(LED) output devices as shown in Figure 27. 
 

 
Figure 27. The workbench interface  

 

In the previous lab, we saw how the least-significant four bits from the output port at address 
$F022 could be used to drive a single decoded 7-segment display. However, as we saw in 
Figure 24, this left the most-significant four bits from the port unused. One obvious solution 
would be to use these four bits to drive a second 7-segment display; and this is the case with 
the output port at address $F023, which is used to drive a dual 7-segment display (Figure 28). 
 

 

Figure 28. Dual decoded 7-segment display  
 
And so, it’s time to create our final program for this series of labs. Use the Tools > Assembler 
command (or click the appropriate icon in the main window’s tool bar) to launch the assembler. 
Use the assembler’s File > Open command to locate and open the wb101-lab3a.asm that we 
created in the third lab, and then use the assembler’s File > Save As command save this out as 
wb101-lab4.asm.  
 
Now modify the program by adding two lines as follows (these modifications are in bold and 
highlighted in gray): 
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SW8BIT1:  .EQU   $F000     # Input port from upper 8-bit switches 
LED8BIT:  .EQU   $F020     # Output port to 8-bit LEDs 
SUD7SEG:  .EQU   $F021     # Output port to single un-decoded 7-segment 
SD7SEG:   .EQU   $F022     # Output port to single decoded 7-segment 
DD7SEG:   .EQU   $F023     # Output port to dual decoded 7-segment 
 

          .ORG   $4000     # Set program origin 
LOOP:      LDA   [SW8BIT1] # Read from upper 8-bit switches 
           STA   [LED8BIT] # Write to 8-bit LED Display 
           STA   [SD7SEG]  # Write to single decoded 7-segment display 
           STA   [DD7SEG]  # Write to dual decoded 7-segment display 
           STA   [SUD7SEG] # Write to single un-decoded 7-segment display 
           JMP   [LOOP]    # Do it all again 
          .END 

 
This program really shouldn’t require any explanation by now. Once you’ve made the above 
modifications, use the assembler’s File > Save command to save your work, and then use the 
assembler’s File > Assemble command to assemble this program into a corresponding 
machine code file, which will be automatically named wb101-lab4.ram. 
 
Click the On/Off button on the calculator’s front panel to power-up the virtual computer; use the 
Memory > Load RAM command in the main window to locate the wb101-lab4.ram machine 
code file you just created and load it into the virtual computer’s memory; and click the Run 
button on the calculator’s front panel to set your program running. 
 
Start clicking the various switches forming 8-Bit Switch Bank 1 and observe what happens on 
the workbench’s various displays (Figure  29). 
 

 

Figure 29. Writing to all of the displays 
 
As usual, once you’ve finished playing, click the Reset button on the calculator’s front panel to 
halt this program, and then click the On/Off button to power-down the virtual computer. 
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